프로젝트 시작

Xcode 프로젝트에서 KakaoMapsSDK를 사용하기 위한 방법.

요구사항


  • iOS13 이상

Installation


KakaoMapsSDK는 Cocoapods / Swift Package Manager 를 통해 배포됩니다. 사용자는 두 배포 방식중에 원하는 방식을 선택하여 프로젝트에 적용할 수 있습니다. KakaoMapsSDK는 xcframework 및 asset bundle 를 제공합니다. xcframework 에는 arm64 및 시뮬레이터(arm64, x64)용 라이브러리가 포함되어 있습니다.

Cocoapods 설정

먼저 cocoapods을 사용하기 위해서는 cocoapods 이 설치되어 있어야 합니다. 설치하지 않은 경우 아래와 같이 설치할 수 있습니다.

코코아팟설치

프로젝트에 추가

xcodeproj에 Podfile을 생성하여 cocoapods 이 KakaoMapsSDK 를 디펜던시로 추가하도록 합니다. 아래는 Podfile의 예시입니다.

platform :ios, '13.0'

source 'https://github.com/CocoaPods/Specs.git'

target 'KakaoMapsSDK-Sample' do
    use_frameworks!

    pod 'KakaoMapsSDK', '2.0.0'
end

Podfile에 KakaoMapsSDK가 추가되었으면 pod install 명령으로 Cocoapods이 dependency로 지정된 라이브러리들을 다운받고 xcworkspace를 구성하도록 합니다. podinstall

자세한 Cocoapods 이용법은 Cocoapods를 참고하시기 바랍니다.

Swift Package Manager 설정

Xcode에서 프로젝트를 열고 File > Swift Packages > Add Package Dependency… 메뉴를 선택합니다.

addpackage

Add Package Dependency… 메뉴를 선택하면 위와 같은 팝업이 나타납니다. 팝업의 우상단의 검색창에 URL(https://github.com/kakao-mapsSDK/KakaoMapsSDK-SPM.git)을 입력하고 Add Package 버튼을 클릭합니다.

정상적으로 패키지가 추가되고 나면

import KakaoMapsSDK
...

와 같이 KakaoMapsSDK를 사용할 수 있습니다.